Transport Layer Security (TLS) 1.2 Protocol Update — July 1, 2018

    Attention Customers:

    Technology in our industry is constantly changing to improve online security.

    In the interest of keeping our customers secure and protected, site visitors using browsers that do not support the Transport Layer Security (TLS) 1.2 Protocol (the latest standard in online security) will not be able to access our site after July 1st, 2018. Please note, this is an internet-wide change for sites that process and transmit credit card data, as older browser versions are more vulnerable to online attacks.

    While most browsers currently support TLS 1.2, the below browsers (and older versions) do not support the latest protocol and will not allow you to access the site once this date has passed:

    Mobile
    • Android 4
    • Blackberry 10
    • iOS 4
    • Kindle Fire HD with Android 4
    • Samsung Internet 3
    Desktop
    • Firefox 26
    • Google Chrome 29
    • Internet Explorer 10
    • Opera 16
    • Safari 6

    Please ensure that your browser is up-to-date so we can continue to provide you with the best and most secure shopping experience possible.
    Loading....